GitLab Upgrade Error : Problem with the SSL CA cert

Dernièrement, j’ai souhaité mettre à jour GitLab grâce au script Ruby Upgrade.rb mais j’ai rencontré un erreur en lançant le script avec l’utilisateur git.

Erreur détectée - GitLab Upgrade Error

1
2
3
4
5
6
7
8
9
10
$ cd /home/git/gitlab
$ ruby script/upgrade.rb
GitLab 6 upgrade tool
Your version is 6.6.5
error: Problem with the SSL CA cert (path? access rights?) while accessing https://github.com/gitlabhq/gitlabhq.git/info/refs
fatal: HTTP request failed
/home/git/gitlab/lib/gitlab/upgrader.rb:47:in `latest_version_raw': undefined method `match' for nil:NilClass (NoMethodError)
    from /home/git/gitlab/lib/gitlab/upgrader.rb:37:in `latest_version'
    from /home/git/gitlab/lib/gitlab/upgrader.rb:8:in `execute'
    from script/upgrade.rb:3:in `<main>'

Solution pour mettre à jour GitLab

Vous pouvez résoudre ce problème simplement en désactivant la vérification du certificat pour la commande en cours.

1
`env GIT_SSL_NO_VERIFY=true` ruby script/upgrade.rb

Ce option sera active uniquement pour la commande en cours.
J’ai pu trouver une solution grâce à ce ticket. Merci à lui !